CentOS 8 Bootable USB macOS

This guide assumes using macOS to generate the bootable media.

Verify the key used to sign the files.

In order to make sure the downloaded files are safe. Get the CentOS key here, or for an older version, here.

Download key.

1
wget https://www.centos.org/keys/RPM-GPG-KEY-CentOS-Official

Verify key fingerprint here.

1
2
3
root@localhost ~> gpg --quiet --with-fingerprint RPM-GPG-KEY-CentOS-Official
pub  4096R/8483C65D 2019-05-03 CentOS (CentOS Official Signing Key) <[email protected]>
      Key fingerprint = 99DB 70FA E1D7 CE22 7FB6  4882 05B5 55B3 8483 C65D

Import key to keychain.

1
gpg --import ./RPM-GPG-KEY-CentOS-8

Download ISO

1
wget http://mirrors.oit.uci.edu/centos/8.0.1905/isos/x86_64/CentOS-8-x86_64-1905-dvd1.iso

Grab checksums from a mirror.

1
wget http://mirrors.oit.uci.edu/centos/8.0.1905/isos/x86_64/CHECKSUM.asc

Verify checksum.

1
gpg --verify ./CHECKSUM.asc

Verify the centos image. If you don’t have brew, you can get it here.

1
2
3
brew install coreutils
sha256sum -c CHECKSUM.asc 2>&1 | grep OK
CentOS-8-x86_64-1905-dvd1.iso: OK

Build bootable media.

From the command line identify the usb disk identifier.

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
➜  ~ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.3 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                 Apple_APFS Container disk1         499.8 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +499.8 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh SSD - Data    198.7 GB   disk1s1
   2:                APFS Volume Preboot                 84.4 MB    disk1s2
   3:                APFS Volume Recovery                528.5 MB   disk1s3
   4:                APFS Volume VM                      5.4 GB     disk1s4
   5:                APFS Volume Macintosh SSD           10.9 GB    disk1s5

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *30.8 GB    disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:       Microsoft Basic Data Untitled                30.5 GB    disk2s2

Unmount the filesystem volumes.

1
2
➜  ~ diskutil unmountDisk /dev/disk2
Unmount of all volumes on disk2 was successful

Use dd command copy the image to the USB.

1
2
3
4
5
➜  ~ sudo dd if=CentOS-8-x86_64-1905-dvd1.iso of=/dev/rdisk2 bs=1m
Password: ************
6805+0 records in
6805+0 records out
7135559680 bytes transferred in 448.409708 secs (15913036 bytes/sec)